+ Reply to Thread
Results 1 to 4 of 4

Thread: Displaying all Labels - how?

  1. #1
    Justina K
    Join Date
    Aug 2010
    Posts
    3
    Points
    0
    Answers Provided
    0


    0

    Question Displaying all Labels - how?

    I have a layer of points that represent different cities and towns in an area, and not all of the labels are showing up.

    There is actually plenty of space in my map for these labels and i have checkmarked the box "Place overlapping labels". I have also tried exporting the labels to annotation and I'm still missing those labels.

    Can anyone help me?

  2. #2
    Donovan Cameron

    Join Date
    Aug 2010
    Posts
    477
    Points
    40
    Answers Provided
    3


    0

    Default Re: Displaying all Labels - how?

    Check the other layers in the map that have labels enabled and ensure that their feature and label weight in the Placement Properties settings are not set too to High where they would then eliminate any overlapping labels from the other layers.

    Also check the feature/label weight for the Place Name shapefile so that those are set to low. Leaving the Feature Weight to a higher setting for the place names might be a good idea, as you may not want to have labels covering your points, as they can be then completely eliminated, visually, from the map as opposed to allowing labels over other lines and polys where there loss of segment/area is more allowable as long as the feature can still be interpreted.

    Would that fix it?


  3. #3
    Justina K
    Join Date
    Aug 2010
    Posts
    3
    Points
    0
    Answers Provided
    0


    0

    Default Re: Displaying all Labels - how?

    Thanks for your reply! I really appreciate it
    I did check the label/feature weights and it didn't help. However, I realized that i had created classes of labels and for some reason, even though they were all set to be labelled, they didn't. I just fixed it by keeping the labels all at one class, which wasn't what I intended to do, but it will work.

    Thanks again!

  4. #4
    Dana Nolan
    Join Date
    Apr 2010
    Posts
    219
    Points
    11
    Answers Provided
    0


    0

    Default Re: Displaying all Labels - how?

    Quote Originally Posted by JustinaK15 View Post
    Thanks for your reply! I really appreciate it
    I did check the label/feature weights and it didn't help. However, I realized that i had created classes of labels and for some reason, even though they were all set to be labelled, they didn't. I just fixed it by keeping the labels all at one class, which wasn't what I intended to do, but it will work.

    Thanks again!
    If an entire class doesn't label, it means the SQL isn't working correctly. In general, unplaced labels can be debugged using Label Manager's Show Unplaced Labels tool and zooming in and out. That will show you what is not fitting. If you have SQL classes, scales, minimum mapping units, remove duplicate, or other parameters that limit what and when things are labeled, the labels dropping out due to those parameters will not show as unplaced labels, nor should they end up in your annotation.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts