+ Reply to Thread
Results 1 to 8 of 8

Thread: Ginormous .mxd file size on ArcGIS 10 Desktop

  1. #1
    Scott Ferguson
    Join Date
    Sep 2010
    Posts
    3
    Points
    0
    Answers Provided
    0


    0

    Default Ginormous .mxd file size on ArcGIS 10 Desktop

    Anyone have any idea why my .mxd file size increase 20 to 30mb in file size each time I save, then close the file? I've used the hidden .mxd document defrag tool which did cut the original file size in half, but now it repeating the process. The file gets larger and larger and larger and larger....grrrr....

    I've used 9.3.1 with no issues in increasing file size...

    There has to be a simple explanation.

    Scott

  2. #2
    Matt Morris
    Join Date
    Apr 2010
    Posts
    59
    Points
    2
    Answers Provided
    0


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    You could try using "save as" and just overwriting the existing mxd file name. That has solved mxd bloat (where the mxd just grows and grows) for me in 9.xxx.

  3. #3
    Scott Ferguson
    Join Date
    Sep 2010
    Posts
    3
    Points
    0
    Answers Provided
    0


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    Thanks Matt. It's just unfortunate there's no explanation behind it. Time to band-aid another ArcGIS 10 issue. I'll give it a shot.

  4. #4

    Join Date
    Apr 2011
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    I had a problem similar to this back in 9.2 and it came back when I installed Arc 10. Try changing your Geoprocessing option for keeping results to 'Never save' (or at least quite a bit shorter than the default of 2 months), clear the results, then resave the mxd. This fixed the problem for me. Hope this helps...

    Andy

  5. #5

    Join Date
    Apr 2011
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    Btw, when I said resave the mxd, I meant to save it as a new mxd (save as)....

    Andy

  6. #6
    Will Allender
    Join Date
    Jul 2010
    Posts
    17
    Points
    0
    Answers Provided
    1


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    Did you ever get a fix for this? I am having a similar issue. My MXD grew to 48 MB. When I did the "Save As" trick, it only went down to 24 MB.

    Before ArcGIS 10, my MXDs were never larger than about 1.5 MB.

    EDIT:
    Just changed the Geoproc save to "Never" and file size is now down to normal.
    Last edited by WillAllender; 04-30-2012 at 12:40 PM.

  7. #7
    Richard Watson

    Join Date
    Nov 2009
    Posts
    1,615
    Points
    479
    Answers Provided
    71


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    http://resources.esri.com/help/9.3/a...3817eed44f.htm

    http://support.esri.com/en/knowledge...s/detail/33187

    MXD files are just OLE structured storage. If you want to see what is in them there are a number of tools which allow you to do this.

    I think that Visual Studio 6.0 has the dfview utility. I have also seen similar utilities written by others.

  8. #8
    NAOMI PAUL
    Join Date
    Apr 2010
    Posts
    66
    Points
    4
    Answers Provided
    0


    0

    Default Re: Ginormous .mxd file size on ArcGIS 10 Desktop

    I have tried this and Save As... and Replace Existing-Yes, isn't working. I changed a feature color and closed a table just to have a visual. I have tried this several times in a row and it is not working.

    ~ODD~

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts