+ Reply to Thread
Results 1 to 30 of 30

Thread: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

  1. #1
    Clay Scott
    Join Date
    Apr 2011
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Unhappy ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    When I attempt to Add a Basemap (e.g. OpenStreetMap, Bing Maps Aerial, etc.) to an empty map in ArcMap 10 it consistently crashes. I'm using ArcMap 10.0 build 2800. Based on what I read in the forums, I turned off the Hardware Acceleration (Customize > ArcMap Options > Data View tab). It still crashes.

    When I try to Add Data from one of ESRI's GIS servers (at server.arcgisonline.com) I can see the various data sources/map services (e.g. USA_Topo_Maps). But when I try to Add it, I first get a Warning message, "Warning, inconsistent extent" (I don't have a map file open at this point). If I click on the OK button, it adds the basemap layer to my map.

    So it appears to be in the "Add Basemap" functionality.

    FWIW, a month ago I was able to Add a Basemap without a hitch.

    Any ideas?

  2. #2
    jeremy wright
    Join Date
    Oct 2009
    Posts
    117
    Points
    8
    Answers Provided
    1


    2

    Lightbulb Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Here are some troubleshooting ideas:
    1. Can you load any of the templates included with ArcGIS? Go to file=>new and choose USA category, choose CentralUSA or any of the other templates. Does this open OK?
    2. Try clearing your caches. Go to the Display Cache tab in ArcMap Options and choose Clear Cache. Then try the basemaps again.

    Beyond this, I would highly recommend you contact technical support for more interactive troubleshooting.
    Jeremy Wright, CSM
    Esri Product Engineer

  3. #3

    Join Date
    Sep 2011
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Hi,
    I have been having a similar issue on my lap top, and wondered if you had solved your problem (and if so how). I had thought about extracting an area from Bing Maps (on my desk top) so that I am not loading too large a file, and then keeping it as a layer file so I don’t need to use Add Basemap each time, however I don’t know how to go about it. Any help would be appreciated.
    Thanks Richard

  4. #4
    Steven Cummings
    Join Date
    May 2011
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I too have been experiencing the issue of system crashing after adding a basemap. Once I realized this was a continuing problem, I started keeping track of the number of times it has crashed. So far, I am on crash #54. I have no idea how to correct this. Like the previous posters, everything was fine until one day the issues began.

  5. #5
    jeremy wright
    Join Date
    Oct 2009
    Posts
    117
    Points
    8
    Answers Provided
    1


    0

    Lightbulb Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Steven,

    Have you tried the two suggestions I posted above?

    Also, can you let us know what version/SP of 10.0 you have? There were several fixes that went into 10.0 SP3 (available at http://resources.arcgis.com/content/...66&MetaID=1802) that may resolve this issue.

    If SP3 doesn't seem to help, please be sure to send the resulting error reports along with any salient information to Esri so we can troubleshoot the issue further.
    Jeremy Wright, CSM
    Esri Product Engineer

  6. 11-09-2011 07:59 AM


  7. #6
    Imran Ghani
    Join Date
    Nov 2011
    Posts
    2
    Points
    2
    Answers Provided
    0


    2

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I have the exact same problem and turning off the hardware acceleration has worked (at least for the last 2 hours). Otherwise, ArcMap 10 would crash constantly.

    1. Go to Customize-> ArcMap Options
    2. Go to the Data View tab.
    3. Uncheck "Enable Hardware Acceleration for supported layers".

    When you bring in a basemap from ArcGIS, it will ask you to turn on "enable hardware acceleration."
    Select No and check the box "don't ask me again" or something like that.

  8. #7
    jeremy wright
    Join Date
    Oct 2009
    Posts
    117
    Points
    8
    Answers Provided
    1


    0

    Question Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    If turning off hardware acceleration fixes the crash, can you let the thread know what kind of graphics card you have, and if possible, what version of the driver? Usually crashing with hardware acceleration indicates an out-of-date or corrupt graphics card driver, or a bug in the driver itself.

    You can find the above information in Device Manager from your Windows Control Panel.
    Jeremy Wright, CSM
    Esri Product Engineer

  9. #8
    Imran Ghani
    Join Date
    Nov 2011
    Posts
    2
    Points
    2
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Graphics Card - ATI Mobility Radeon X1400

    Driver Provider - ATI Technologies Inc.
    Driver Version - 8.561.0.0

    (running Windows 7 Professional)

  10. #9
    jeremy wright
    Join Date
    Oct 2009
    Posts
    117
    Points
    8
    Answers Provided
    1


    0

    Unhappy Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    A quick search indicates that is an older (circa 2006 or so) chipset. AMD (who now owns ATI) no longer makes drivers available for this chipset - so the version that's installed is most likely the OEM driver included with Win7.

    In all likelihood, you will need to proceed with hardware acceleration disabled. It does appear that newer version of the driver is available through sources other than the manufacturer for XP, but no drivers are available for Win7.

    Incidentally, this is why we didn't turn on hardware acceleration by default - you are prompted to enable it the first time you use Basemap Layers, and you have to turn it on yourself.
    Last edited by testy; 11-22-2011 at 04:51 PM. Reason: added info about default hardware acceleration
    Jeremy Wright, CSM
    Esri Product Engineer

  11. #10
    Larry Prentice
    Join Date
    Feb 2011
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I had this same problem but I followed the steps above for clearing the "Display Cache" under ArcMap options and that seemed to work.

  12. #11
    Danielle Hartman
    Join Date
    Aug 2010
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I am having the same problem. I tried the 2 fixes and there was no change. I am using a standalone license and SP3.

  13. #12
    Kirill G
    Join Date
    Apr 2012
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Quote Originally Posted by comcarto View Post
    I am having the same problem. I tried the 2 fixes and there was no change. I am using a standalone license and SP3.
    Try updating to SP 4 http://resources.arcgis.com/content/...66&MetaID=1843 and apply this patch () http://resources.arcgis.com/content/...60&MetaID=1782

    Hope this helps.

  14. #13
    Ryan Cosby
    Join Date
    May 2012
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I was having problems with this the other day and then I went and installed the updates to Java on my computer and everything was fixed.

  15. #14
    NAVIN THAPA
    Join Date
    Jun 2012
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I am having same problem with one one computer in our office and unchecking hardward accelerator is not helping. Please suggest a fix.

    Nav

  16. #15
    Naeim Dastgir
    Join Date
    Jul 2011
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I'm having similar but not the same problem. when I select a basemap layer to add, nothing happens at all. I get no error message at all. funny enough, it used to work before. it seems like it has stopped working after I installed SP3.
    any thoughts anyone?

  17. #16
    Allison Plummer
    Join Date
    Feb 2012
    Posts
    9
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Hi,

    I am also having an issue with crashing when I try to add a Basemap, and like many on this thread, there used to be no issue with basemaps. I am running ArcMap 10.0 with Service Pack 5 and I've run the scan to make sure my computer has the capabilities to run ArcMap (it is well beyond all the minimum requirements). I've tried unchecking the graphic accelerator option as well as clearing my cache and updating to the latest version of Java. None of this seems to work. Are there any other thoughts on how to remedy this issue?

    Any help would be much appreciated!

    -Allison

  18. #17
    Karen Wolf
    Join Date
    Jan 2012
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Quote Originally Posted by akp15 View Post
    Hi,

    I am also having an issue with crashing when I try to add a Basemap, and like many on this thread, there used to be no issue with basemaps. I am running ArcMap 10.0 with Service Pack 5 and I've run the scan to make sure my computer has the capabilities to run ArcMap (it is well beyond all the minimum requirements). I've tried unchecking the graphic accelerator option as well as clearing my cache and updating to the latest version of Java. None of this seems to work. Are there any other thoughts on how to remedy this issue?

    Any help would be much appreciated!

    -Allison
    Hi, I am having the exact same problem as Allison. I am on ArcMap 10.0 Build 4400, SP 5. None of the suggestions seem to help!
    Thanks,
    Karen

  19. #18
    Adam Cox
    Join Date
    Dec 2012
    Posts
    51
    Points
    36
    Answers Provided
    3


    1

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Hello I'd just like to say that clearing the cache is all I had to do. When I saw that suggestion it made sense because I've been digitizing all around the US, but recently when I focused on a new area the basemap was crashing. Thanks!! It was up to 6.2gb...

  20. #19
    Bob Jones
    Join Date
    May 2013
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Unhappy Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    my ArcMap has just started doing this and it is very convenient around my warranty expiring. it was running absolutely flawlessly until about three weeks ago. i loaded the patch and it got MONUMENTALLY WORSE. now it wont even let me see the basemap screen , just blank i am such a big fan but am really on my way down this is ridiculous. i cant even make a map anymore except with my local data

  21. #20
    Kate Johnson
    Join Date
    Dec 2010
    Posts
    32
    Points
    2
    Answers Provided
    2


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    This has just started happening to me with ArcMap 10.1. I've never had a problem adding a basemap until the service for Bing Maps was revoked.. not sure if that has anything to do with it at all. I'll try clearing the cache and see what happens.


    Edit: Wow, my cache was 1.29 GB. Was not expecting that. Add Basemap worked pretty quickly after I cleared it.
    Last edited by kmjohnson; 05-23-2013 at 01:32 PM.

  22. #21
    Bob Jones
    Join Date
    May 2013
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    it really cant be tied to BING because my "add basemap" and "add basemap from ArcGIS online " just comes up as a clear block??? then locks up my application

  23. #22
    Kate Johnson
    Join Date
    Dec 2010
    Posts
    32
    Points
    2
    Answers Provided
    2


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Quote Originally Posted by bjones60 View Post
    it really cant be tied to BING because my "add basemap" and "add basemap from ArcGIS online " just comes up as a clear block??? then locks up my application
    Bob, have you tried clearing your cache? That's what worked for me.

  24. #23
    Alex Westerlund
    Join Date
    Jun 2013
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Quote Originally Posted by kmjohnson View Post
    Bob, have you tried clearing your cache? That's what worked for me.
    This worked for me as well. You just go to the customize tab, ArcMap Options, Display Cache, then click clear cache.

    Thank you

  25. #24
    Jennifer Horsman
    Join Date
    Jan 2011
    Posts
    16
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Something similar started happening to me also - about a month or so ago and it has gotten increasingly worse with time. I can open a basemap layer and view it, but after a varying amount of panning and zooming, the layer fails to load. For several months, I was able to pan and zoom as much as I wanted to, and I did it a lot. But now, sometimes it stalls after only a few pans and zooms. Sometimes, although rarely, the basemap won't load at all. This happens with any of the basemaps available, though I really only want to use the aerial imagery layer (BING).

    I have tried clearing the cache, it speeds up redraw, but it doesn't solve my problem. I have tried many things including removing any custom tools, deleting the Template.mxt, and deleting the folders ArcGIS sets up when an application is run for the first time. I am running ArcGIS 10 Service Pack 3 on a 64 bit machine (12 GB RAM) with a NVIDIA GeForce GTX 560 Ti graphics card with 1280 MB dedicated memory. I have some idea it might have something to do with the graphics card, but my IT person loaded the latest drivers and it did not help my situation. However, I had some crashing of Google Earth a few months ago when I had GE, BING Bird's Eye, and ArcMap with BING all open at the same time. ArcMap would also crash.

    My IT person also removed Java from my computer and then loaded the most recent version a few days later. Neither of these actions helped my problem. These are the only real changes to my computer since the basemap began stalling in ArcMap, except for updates to Adobe Reader and Adobe Flash Player.

  26. #25
    Jennifer Horsman
    Join Date
    Jan 2011
    Posts
    16
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I had my IT person install the latest service pack last night. Unfortunately, installing SP5 did not help at all. I panned around in the basemap a few times, then when I zoomed out, it stalled. Another thing, I can usually turn the basemap layer off so that I can then save my map, but if I try to turn it back on, then the ArcMap application freezes completely and I have to use Task Manager to kill it.

    Argh!

  27. #26

    Join Date
    Jul 2013
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I have been having this problem for the past two days and clearing my cache on ArcMap wasn't working so I decided to go further than that. Type %temp% into the windows search box under the window start menu. Should take you to C:\Users\username\AppData\Local\Temp folder. Just select all and delete, skip all when a prompt box appears. This made it work immediately for me after not working for hours.

  28. #27
    Angelina LeBlanc
    Join Date
    Jan 2013
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Quote Originally Posted by RehakC View Post
    I have been having this problem for the past two days and clearing my cache on ArcMap wasn't working so I decided to go further than that. Type %temp% into the windows search box under the window start menu. Should take you to C:\Users\username\AppData\Local\Temp folder. Just select all and delete, skip all when a prompt box appears. This made it work immediately for me after not working for hours.
    Thank you everyone for these postings. I had the same issues, and every time I tried to export a mapbook of 20 figures using data driven pages it would freeze after 4 pdf's. After I deleted the Temp folder of 1GB (also trying all the other suggestions-deleted cache at 6.5GB) my export froze after 7 pages.

    I have been exporting using the BING layer, which is also available until September 2013 until a charge is tacked onto your license.

    I have noticed some new areas of BING with updated orthophotos, thinking maybe Microsoft is going through some updating ?

    Anyways, my ArcMap 10.0 continues to crash....... still hoping for an answer. Thank you !

  29. #28
    Angelina LeBlanc
    Join Date
    Jan 2013
    Posts
    2
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    Quote Originally Posted by HockeyHalo View Post
    Thank you everyone for these postings. I had the same issues, and every time I tried to export a mapbook of 20 figures using data driven pages it would freeze after 4 pdf's. After I deleted the Temp folder of 1GB (also trying all the other suggestions-deleted cache at 6.5GB) my export froze after 7 pages.

    I have been exporting using the BING layer, which is also available until September 2013 until a charge is tacked onto your license.

    I have noticed some new areas of BING with updated orthophotos, thinking maybe Microsoft is going through some updating ?

    Anyways, my ArcMap 10.0 continues to crash....... still hoping for an answer. Thank you !
    After IT looking into my issue as mentioned above, they discovered my machine had automatically updated to Internet Explorer 10.

    Once we removed the update, the issue with BING was resolved.

    Hope it works for you too ! Cheers,a

  30. #29
    Jennifer Horsman
    Join Date
    Jan 2011
    Posts
    16
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    I also had recently updated to IE 10, so I asked my IT admin to remove it. He remembered an option that automatically gets checked when IE is updated or when a new version is installed. He unchecked it and that completely fixed the problem - no need to uninstall or go back to a later version.

    In Internet Options (available through control panel or by clicking on the settings button in IE 10), click on the "Connections" tab, then click on the "LAN Settings" button. uncheck "Automatically detect settings".

    That's it! At least, it worked for me.

  31. #30

    Join Date
    Apr 2014
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcMap 10 crashes when adding a BaseMap Layer from ESRI

    As noted above - THIS IS THE SOLUTION TO THIS PROBLEM. Blows me away that ESRI has not made a more accessible help topic on this issue.

    In Internet Options (available through control panel or by clicking on the settings button in IE 10), click on the "Connections" tab, then click on the "LAN Settings" button. uncheck "Automatically detect settings".

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts