+ Reply to Thread
Results 1 to 3 of 3

Thread: Proxy Issues from 2.3 to 2.4 (I think it's proxy)

  1. #1
    Matt Shetzer
    Join Date
    Jul 2010
    Posts
    83
    Points
    0
    Answers Provided
    0


    0

    Default Proxy Issues from 2.3 to 2.4 (I think it's proxy)

    I've upgraded my SFV from 2.3 to 2.4 this weekend, and all is well except for one of my referenced basemaps.

    I've used a proxy for this in 2.3 since the site does not have a crossdomain file and everything has been running great. Now, in 2.4 I'm getting this error when I'm running from the web server (I don't get the error when running through flex builder)

    MYLAYER layer failed to load: Fault code: Channel.Security.Error
    Fault info: Security error accessing url
    Fault details: Destination: DefaultHTTP

    The base map is at this location:
    http://gis.apfo.usda.gov/ArcGIS/rest...NC/ImageServer

    and my proxy on the server is:
    <serverUrl url="http://gis.apfo.usda.gov/ArcGIS/rest/services/NAIP/Colorado_2009_1m_NC/ImageServer"
    matchAll="true"></serverUrl>
    </serverUrls>

    In my config.xml I’ve got this:
    <httpproxy>http://MYSERVER/Proxy/proxy.ashx</httpproxy>

    <layer label="Colorado NAIP" type="image" useproxy="true" visible="false" alpha="1" url="http://gis.apfo.usda.gov/ArcGIS/rest/services/NAIP/Colorado_2009_1m_NC/ImageServer"/>



    So I ask, what has changed between v2.3 and v2.4 in relation to proxy, or is there something else going on?

    Thanks for your help.
    Matt Shetzer

  2. #2
    Matt Shetzer
    Join Date
    Jul 2010
    Posts
    83
    Points
    0
    Answers Provided
    0


    0

    Default Re: Proxy Issues from 2.3 to 2.4 (I think it's proxy)

    Anyone from ESRI on this one?
    Has anything changed regarding proxy from 2.3 to 2.4?
    Thanks,
    Matt Shetzer

  3. #3
    Bjorn Svensson

    Join Date
    Sep 2009
    Posts
    1,090
    Points
    439
    Answers Provided
    70


    0

    Default Re: Proxy Issues from 2.3 to 2.4 (I think it's proxy)

    Quote Originally Posted by mshetzer View Post
    So I ask, what has changed between v2.3 and v2.4 in relation to proxy, or is there something else going on?
    My guess is "something else [is] going on". I don't think there were any proxy related changes in v2.4. My first guess would be that you deployed it differently.

    Are you running your application at the same URL as before, or a different machine? What's the exact URLs of the working and non-working apps? What does httpfox/fiddler/charles say?

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts