+ Reply to Thread
Results 1 to 3 of 3

Thread: Error deploying geoportal SP2 on Glassfish 3.1.1 (build 12)

  1. #1
    Brandur Sigurjonsson
    Join Date
    Aug 2010
    Posts
    10
    Points
    0
    Answers Provided
    0


    0

    Exclamation Error deploying geoportal SP2 on Glassfish 3.1.1 (build 12)

    I am currently running geoportal SP1 on test and production environments.

    I have uneployed SP1 and restarted the server. When I deploy the SP2 geoportal.war I get the following error.

    Error occurred during deployment: Exception while loading the app : java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: org.apache.catalina.LifecycleException: java.lang.ClassNotFoundException: javax.faces.webapp.FacesServlet not found by org.glassfish.web.core [208]. Please see server.log for more details.

    If I try to deploy the 1.2 geoportal.war from geoportal.sf.net I have no problems.

    Attached is the glassfish server.log showing the errors in more detail.

    I'm proceeding with comparing the contents of the two war's (apart from the viewer added in ArcGIS for INSPIRE) to see if I can find anything there. Thought I'd check if someone else has run into the same problems.

    Any ideas

    Update: I have compared the two and there is nothing ovbious in the config files that justifies the errors. Hmm, contradiction in terms, at least I cannot find anything that makes sense to me.
    Attached Files
    Last edited by brandur; 02-23-2012 at 05:24 AM. Reason: Update to information

  2. 02-24-2012 02:27 AM

    Reason
    Brandur is my coworker so no need to double posting

  3. #2
    Brandur Sigurjonsson
    Join Date
    Aug 2010
    Posts
    10
    Points
    0
    Answers Provided
    0


    0

    Red face Re: Error deploying geoportal SP2 on Glassfish 3.1.1 (build 12) - FIXED

    rlucchi provided the fix, see : http://goo.gl/CHyrG

    Thanks.

    In short it is:

    unzip the war, remove /META-INF/context.xml, recreate the war, deploy, life is good again

  4. #3

    Join Date
    Mar 2012
    Posts
    8
    Points
    0
    Answers Provided
    0


    0

    Default Re: Error deploying geoportal SP2 on Glassfish 3.1.1 (build 12)

    Relly?It is cool!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts