+ Reply to Thread
Results 1 to 8 of 8

Thread: Simple Data Loader will not open

  1. #1
    John Kizer
    Join Date
    Feb 2012
    Posts
    4
    Points
    4
    Answers Provided
    1


    0

    Default Simple Data Loader will not open

    Step 3A on page 142. Load is in bold, but "Load Data" is not selectable; therefore, I can't open the Simple Data Loader. Any advice?

  2. #2
    Tim Ormsby
    Join Date
    Apr 2010
    Posts
    74
    Points
    5
    Answers Provided
    8


    0

    Default Re: Simple Data Loader will not open

    Hi,

    There are special cases where the Simple Data Loader can't be used, but it doesn't seem like they shouldn't affect you. (They usually come up when the data is involved in behavioral relationships with other data. More about this in the help topic Loading Data in the Catalog Tree.) Another problem might be if the feature class you're loading into (Parks) has a corrupted OBJECTID field. None of these seems likely, so I'm not sure what's going on.

    As an alternative you can use the Append geoprocessing tool. Go like this:
    1. Open the Append (Data Management) tool from the Search window.
    2. Set the Input Datasets to New Parks.
    3. Set the Target Dataset to Parks.
    4. Set the Schema Type to NO_TEST (lets you append data when field names don't match).
    5. In the Field Map area, right-click the TYPE field and choose Add Input Field.
    6. In the list of available fields (full paths are used, so you may have to widen the dialog box), click CATEGORY and click OK. (This assigns values from the CATEGORY field in NewParks to the TYPE field in Parks, equivalent to steps H and I on p. 143).
    7. Click OK to run the Append tool.

    This should give you the same result you see in Figure 4-43 on page 145 of the book.

    If you try this, let me know how it turns out. Here's a link to online help for the Append tool.

    We can also try and troubleshoot the Load Data problem offline. If you want to do that, send an e-mail to UnderstandingGIS@esri.com.

    Thanks,

    Tim

  3. #3
    John Kizer
    Join Date
    Feb 2012
    Posts
    4
    Points
    4
    Answers Provided
    1


    0

    Default Re: Simple Data Loader will not open

    Hi Tim,

    The Append did not work. Error 000262: Target Parks is read-only. I'm trying to figure out how to turn this off, but I don't see it under properties. Where is this feature hidden???

    Thanks for your help, John

  4. #4
    Tim Ormsby
    Join Date
    Apr 2010
    Posts
    74
    Points
    5
    Answers Provided
    8


    0

    Default Re: Simple Data Loader will not open

    Hi John,

    Sorry for the trouble. To change read/write permissions on files, you have to use Windows Explorer, not ArcGIS. Try this: In Windows Explorer, right-click the folder name (start with the UGIS folder) and choose Properties. On the General tab of the Properties dialog box, uncheck the Read-Only box at the bottom and click OK. You'll be prompted to apply the changes to all subfolders. Click OK again. I hope this does the trick. (Maybe this is where the original Load Data problem comes from, too.)

    If after that, you still have problems with Load Data or Append, try downloading the Lesson 3 results folder from the Lesson Results page on our web site. This will set you back to the beginning of Lesson 4, so you'll have to cover a bit of old ground (but not too much) to get back to page 142. In fact, you might want to go to the trouble of sequentially downloading the results for Lessons 1, 2, and 3 to make sure all files with read/write problems are replaced.

    When you originally installed the project data from the DVD, did you do it by clicking the Esri.exe file? (See attached graphic.) If not--if you directly copied the files instead--that might explain why the permissions weren't set correctly for you to begin with. Doing a reinstall at this point would amount to starting over, though, so downloading lesson results from the web site is better.

    Again, sorry for the inconvenience. Let me know if any of these suggestions get it sorted out for you. If not, we'll go back to the drawing board.

    Tim
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	UGISDataInstaller.png‎
Views:	57
Size:	15.0 KB
ID:	12366  

  5. #5
    John Kizer
    Join Date
    Feb 2012
    Posts
    4
    Points
    4
    Answers Provided
    1


    0

    Default Re: Simple Data Loader will not open

    Tim,

    When I change it in Windows Explorer it does not stay changed. All the Lessons I downloaded showed it as being read only and would not change. I tried reloading the data from the DVD and the InstallShield Wizard automatically does it from the DVD. Again this is read only and cannot be changed. I tried by clicking on Esri.exe and the InstallShield Wizard loads it as read only. When I look at the properties of the ESRI Application(exe.) it says read only and when I try to change it it says I need Administrator permission. It will not let me be the Admistrator.

    Any more suggestions? Thanks, John

  6. #6
    Tim Ormsby
    Join Date
    Apr 2010
    Posts
    74
    Points
    5
    Answers Provided
    8


    0

    Default Re: Simple Data Loader will not open

    Hi John,

    What do you see if you view the properties of the data in ArcCatalog? (See below for steps to do this.) For me, it's like this: when ArcCatalog looks at the data on the DVD, it has the property "R" (read-only). But when I copy the data from the DVD to my local drive (even with just a straight file copy, not through the data installer), ArcCatalog sees it as "W" (writable). Interestingly, Windows Explorer still shows it as read-only.

    Attached images show the two cases.

    To make ArcCatalog show the read/write property, follow these steps:
    1. Start the ArcCatalog application.
    2. From the Customize menu, choose ArcCatalog Options.
    3. Click the Contents tab.
    4. In the top window, check the Read/Write box.
    5. Click OK.

    Now, in ArcCatalog, the Contents tab will show the Read/Write status for files and folders. If you see "W," then give those original operations (Load Data, Append) another try. If you see, "R" -- even after having installed the data with the Data Installer -- or if the operations still don't work, I'll try to get a tech support person to help.

    There is a Microsoft support page on changing the read/write attributes on files through the CMD window when you can't do it through the file properties. It's here: http://support.microsoft.com/kb/326549 if you want to look at it. But I don't think you should have to go down this path.

    Let me know what happens.

    Tim
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	DataIsReadOnly.png‎
Views:	53
Size:	22.7 KB
ID:	12401   Click image for larger version

Name:	DataIsWritable.png‎
Views:	51
Size:	20.9 KB
ID:	12402  

  7. #7
    John Kizer
    Join Date
    Feb 2012
    Posts
    4
    Points
    4
    Answers Provided
    1


    0
    This post is marked as the answer

    Default Re: Simple Data Loader will not open

    Tim,

    I converted it to Write in ArcCatalog and everything has a "W". However, when I try to Append it still gives the same "Read Only" error. I moved on to Step 5 and also created a Parks3 from the NewParks feature. I was then able to use the Simple Data Loader to combine Parks3 with Parks2.

    Thanks for all your help, John

  8. #8
    Tim Ormsby
    Join Date
    Apr 2010
    Posts
    74
    Points
    5
    Answers Provided
    8


    0

    Default Re: Simple Data Loader will not open

    Hi John,

    glad you found a way to work through it. FYI, the attached text file has information from an Esri tech analyst who looked at the problem. May be helpful if this comes up again.

    Tim
    Attached Files

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts