+ Reply to Thread
Results 1 to 3 of 3

Thread: I got error java.lang.IllegalArgumentException: No configs match configSpec

  1. #1
    Viren Savaliya
    Join Date
    Dec 2011
    Posts
    11
    Points
    2
    Answers Provided
    0


    1

    Default I got error java.lang.IllegalArgumentException: No configs match configSpec

    Hello,

    I got following error in eclipse , I used macbook pro And ran sample project of Arc GIS.

    System information

    Macbook pro. intel i5 , 4GB Ram
    Eclipse Galilo.


    03-05 16:24:03.774: E/AndroidRuntime(563): FATAL EXCEPTION: GLThread 75
    03-05 16:24:03.774: E/AndroidRuntime(563): java.lang.IllegalArgumentException: No configs match configSpec
    03-05 16:24:03.774: E/AndroidRuntime(563): at com.esri.android.map.MapSurface$a.chooseConfig(Unknown Source)
    03-05 16:24:03.774: E/AndroidRuntime(563): at android.opengl.GLSurfaceView$EglHelper.start(GLSurfaceView.java:1009)
    03-05 16:24:03.774: E/AndroidRuntime(563): at android.opengl.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1362)
    03-05 16:24:03.774: E/AndroidRuntime(563): at android.opengl.GLSurfaceView$GLThread.run(GLSurfaceView.java:1216)


    Please help me .
    Last edited by virensavaliya; 03-05-2012 at 02:15 AM.

  2. #2

    Join Date
    Mar 2012
    Posts
    1
    Points
    3
    Answers Provided
    0


    3

    Default Re: I got error java.lang.IllegalArgumentException: No configs match configSpec

    Is this error when you're using an emulator? It may be that the emulator doesn't support openGL ES 2.0.

    Try on a device and see if you still get this same error.

    Reference thread: http://forums.arcgis.com/threads/480...or-Loading-Map

  3. #3
    Viren Savaliya
    Join Date
    Dec 2011
    Posts
    11
    Points
    2
    Answers Provided
    0


    0

    Thumbs up Re: I got error java.lang.IllegalArgumentException: No configs match configSpec

    Quote Originally Posted by ghchinoy View Post
    Is this error when you're using an emulator? It may be that the emulator doesn't support openGL ES 2.0.

    Try on a device and see if you still get this same error.

    Reference thread: http://forums.arcgis.com/threads/480...or-Loading-Map
    Thanks

    for reply, its working.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts