+ Reply to Thread
Results 1 to 3 of 3

Thread: Why are some fields showing up in the attribute window as light-green in 10?

  1. #1
    Jeremy Read
    Join Date
    Jul 2010
    Posts
    44
    Points
    5
    Answers Provided
    0


    0

    Default Why are some fields showing up in the attribute window as light-green in 10?

    We recently upgraded from ArcGIS 9.3.1 to 10. In ArcMap, when I am editing features, I've noticed on the attribute window that some of the fields are showing up in light green. On those fields, the values are not in a drop down combo box like they were in all the previous versions, instead there is a button with three "dots" on it, and I have to click that to then select a value. This is only on certain fields, and a few times when I've selected a value ArcMap will subsequently crash. What is going on here? Does it have something to do with the layer files? Do they work differently in 10 than they did in 8.x-9.x?

    I have included some screenshots that illustrate what I am talking about. You can see the "green" fields in the attribute window, and you can see how I get the "button" in one of those fields, but the regular drop-down in the field right below it.

    If you have any suggestions why this is happening and what I need to do to fix it, I would appreciate it very much.

    Click image for larger version

Name:	Untitled.jpg
Views:	64
Size:	99.7 KB
ID:	13425

  2. #2
    Rhonda Glennon

    Join Date
    Oct 2009
    Posts
    306
    Points
    97
    Answers Provided
    13


    1
    This post is marked as the answer

    Default Re: Why are some fields showing up in the attribute window as light-green in 10?

    The green shading indicates that the field is being used to symbolize the layer. (There is currently no option to change the shading colors.) See the diagram in this help topic for more about the components of the Attributes window:
    http://help.arcgis.com/en/arcgisdesk...00000m1000000/

    Symbology and other layer properties are utilized more in editing in ArcGIS 10 than in ArcGIS 9--for example, feature templates are based on the layer symbols. So, you see a window with the list of unique values symbols in it when you edit the contents of a field used to symbolize the layer. Fields with domains or subtypes that are not used for symbology show the regular drop-down.

    Make sure you have installed ArcGIS 10 service pack 4. This is the newest and includes all the previous service pack fixes, too. Your crash is a bug that was fixed in one of the service packs.
    Esri Product Engineer
    ArcGIS for Desktop team

  3. #3
    Jeremy Read
    Join Date
    Jul 2010
    Posts
    44
    Points
    5
    Answers Provided
    0


    0

    Default Re: Why are some fields showing up in the attribute window as light-green in 10?

    Thank you very much for your help! I will install SP4 and see if that fixes the crashes.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts