+ Reply to Thread
Results 1 to 3 of 3

Thread: Server 10.1 Web Adaptor application pool .NET version affects configuration

  1. #1
    Judy Troutwine
    Join Date
    Jul 2010
    Posts
    60
    Points
    0
    Answers Provided
    6


    0

    Default Server 10.1 Web Adaptor application pool .NET version affects configuration

    After installing SP1 for Server 10.1 and also the web adaptor for IIS, the configuration for the web adaptor is successful. The
    IIS application pool, ArcGISWebAdaptorAppPool, is automatically set to .NET version 2.0.

    After changing the .NET version to 4.0, the Web Adaptor no longer configures correctly. It seems to configure; however, the rest services directory page does not launch correctly.

    Ideas?

  2. #2
    Richard Watson

    Join Date
    Nov 2009
    Posts
    1,622
    Points
    480
    Answers Provided
    72


    0

    Default Re: Server 10.1 Web Adaptor application pool .NET version affects configuration

    On a related note, does anyone here have a link to an ESRI article which describes the position of ArcGIS Server with regards to support of the 4.0/4.5 framework?

    There is such an article for Desktop/Engine.

  3. #3
    Richard Watson

    Join Date
    Nov 2009
    Posts
    1,622
    Points
    480
    Answers Provided
    72


    0
    This post is marked as the answer

    Default Re: Server 10.1 Web Adaptor application pool .NET version affects configuration

    I'd leave the web adaptor alone, i.e. run it as ESRI configures it.

    I wish that ESRI posted a clear postion statement on the 4.0/4.5 framework but I cannot find it.

    We definitely use the later frameworks but leave the web adaptor untouched.

    The only value I can see in running it with the 4.0 framework is that you might be able to avoid having to install 2.0/3.5 on the server. I just installed ArcGIS Server 10.1 SP1 on Windows Server 2012 and had to install 2.0/3.5 because ArcGIS Server required it.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts