+ Reply to Thread
Results 1 to 4 of 4

Thread: Schematic: need to avoid link overlap in Smart tree layout algorithm.

  1. #1
    Rajesh Mane
    Join Date
    May 2010
    Posts
    34
    Points
    0
    Answers Provided
    0


    0

    Default Schematic: need to avoid link overlap in Smart tree layout algorithm.

    Hi ,

    I am generating Schematic diagram (using standard builder) in that I have used Smart tree layout algorithm. i did set its properties values as given below.

    Spacing: nodes particular to the direction = 4
    Spacing: nodes along the direction = 2
    Between Subtrees : 1
    link Display ; orthogonal
    Direction; From top to bottom.

    but in some cases i getting overlaps when one edge passing through. its shows that One edge is connecting 1 node to another node element. but in between it overlaps other edges and node elements. Which is unavoidable. I have tried applying Crossings but crossing did not applied for this particular case. Please see the attachment and requesting for quick assistant. As it is giving wrong representation.

    Regards,
    Rajesh Mane
    Project Lead (UTILITY GIS)
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	Overlap.JPG‎
Views:	156
Size:	76.3 KB
ID:	1509  

  2. #2
    Rick Anderson
    Join Date
    Oct 2009
    Posts
    166
    Points
    83
    Answers Provided
    16


    0

    Default Re: Schematic: need to avoid link overlap in Smart tree layout algorithm.

    Yes, the Mark Crossings command doesn't currently put a crossmark on an edge when it crosses over a node. It only puts a crossmark in place when and edge crosses another edge and those edges are exactly horizontal and vertical (doesn't work on an angle). There is a Bypass Nodes command you can run that will offset edges that cross over other nodes. See the attached with the 2 different cases.
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	CrossMarks.png‎
Views:	80
Size:	16.8 KB
ID:	1523  

  3. #3
    Rajesh Mane
    Join Date
    May 2010
    Posts
    34
    Points
    0
    Answers Provided
    0


    0

    Default Re: Schematic: need to avoid link overlap in Smart tree layout algorithm.

    Thanks Rick for quick response. Bypass node worked in this case. but when I have applied crossing then crossing symbol did not placed on intersection of the link. how to place crossing in this case.

    I have done maximum things through configuration level. Is that possible find overlaps at diagram generation level and use bypass node. If crossing doesnt work I dont mind. But it should bypass the nodes
    Rajesh Mane
    Project Lead(Utility GIS Solutions)
    RMSI India Pvt Ltd
    rajeshvmane@gmail.com

  4. #4
    Rick Anderson
    Join Date
    Oct 2009
    Posts
    166
    Points
    83
    Answers Provided
    16


    0

    Default Re: Schematic: need to avoid link overlap in Smart tree layout algorithm.

    Have you looked at the Composite Algorithm? It is not available by default. You can enable it in Designer. Select the diagram type and then go to layouts tab and make sure it is turned on. Now you can set that as the default layout for your diagram type. You can then stack a number of algorithms to run in a chain. So you can add the smart tree with all the correct parameters and after that the bypass nodes. Since this is the default, it will be automatically applied when a user generates a diagram.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts