+ Reply to Thread
Results 1 to 4 of 4

Thread: Extrude between wrong on the edge, ArcScene

  1. #1
    Helge Aasen
    Join Date
    Feb 2013
    Posts
    6
    Points
    1
    Answers Provided
    1


    0

    Default Extrude between wrong on the edge, ArcScene

    Hey,

    I'm trying to extrude between two Tins which are equally shaped. However if Extrude Between those Tins using input feature created by minimal_bounding from one of them I get a strange error that two sides of my extruded block are inclined and thus the result is wrong (please have a look at the img attached).

    I have absolutely know clue what could be the reason. I would be very glad for comments. Thank you.
    I'm using ArcScene with ArcGis10.1
    This question can also be found on:
    http://gis.stackexchange.com/questio...-edge-arcscene
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	1.jpg‎
Views:	57
Size:	258.8 KB
ID:	21903   Click image for larger version

Name:	4.jpg‎
Views:	53
Size:	53.3 KB
ID:	21904   Click image for larger version

Name:	2.jpg‎
Views:	54
Size:	146.6 KB
ID:	21905   Click image for larger version

Name:	3.jpg‎
Views:	56
Size:	198.4 KB
ID:	21906  
    ArcGIS 10.1 SP1 for Desktop (Build 3143), License Type: Advanced
    Windows 7 Enterprise, SP1. 64 bit

  2. #2
    Helge Aasen
    Join Date
    Feb 2013
    Posts
    6
    Points
    1
    Answers Provided
    1


    0

    Default Re: Extrude between wrong on the edge, ArcScene

    Im asking again, since I couldn't find a solution and the problem is becoming urgent!

    What I did is to take my elevation data and created a tin from it. For the same points I created surface elevation data by adding a 0 as elevation and created a tin from that as well. Than I created a minimum bounding from those points using envelope (and RECTANGLE_BY_AREA with no difference). Than I used the extrude between tool with with elevation tin, surface tin and the minimum bounding as input feature class.
    The result is, that two sides (north and east) are sloped as you can see in the pictures I attached in my posts.

    I have no idea how this is possible ... please help.
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	extrudeb_error1.jpg‎
Views:	38
Size:	154.1 KB
ID:	22629   Click image for larger version

Name:	extrudeb_error2.jpg‎
Views:	41
Size:	55.8 KB
ID:	22630  
    ArcGIS 10.1 SP1 for Desktop (Build 3143), License Type: Advanced
    Windows 7 Enterprise, SP1. 64 bit

  3. #3
    Helge Aasen
    Join Date
    Feb 2013
    Posts
    6
    Points
    1
    Answers Provided
    1


    1
    This post is marked as the answer

    Default Re: Extrude between wrong on the edge, ArcScene

    Thanks to a helpful staff from esri/de (Thomas Hack) I was able to solve the Problem with a workaround:

    Using a polygon which is slightly smaller produces a multipatch which does not have a dip. In addition I figured out that the point position from the nodes for both tins should be at the same x,y position to get good results of the extrusion.

    The Bug is listed at http://support.esri.com/en/bugs/nimbus/TklNMDY5MDQw
    ArcGIS 10.1 SP1 for Desktop (Build 3143), License Type: Advanced
    Windows 7 Enterprise, SP1. 64 bit

  4. #4

    Join Date
    Oct 2013
    Posts
    1
    Points
    0
    Answers Provided
    0


    0

    Default Re: Extrude between wrong on the edge, ArcScene

    Thank you Helge Aasen (I hope I have spelt your name correctly), your solution/answer has solved me a massive problem.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts