+ Reply to Thread
Results 1 to 4 of 4

Thread: ArcPad 10: No GPS on GeoXH

  1. #1
    Jason Weis
    Join Date
    Jan 2010
    Posts
    23
    Points
    1
    Answers Provided
    0


    0

    Unhappy ArcPad 10: No GPS on GeoXH

    I did a clean install of ArcPad 10 on a Trimble GeoXH (2008 series). Previously, I had been running the beta version (Beta 2) with no GPS issues, just slow performance. With the "final" version installed, performance is much better, but I cannot connect to the internal GPS. Because Trimble GPScorrect is not compatible with ArcPad 10 at this time (per my Trimble vendor), I uninstalled it, so I am only running ArcPad 10 on the unit.

    I've tried both COM2 (NMEA serial port) and COM3 (TSIP serial port) in ArcPad, but nether one receives a GPS signal. I can go into the GPS Controller application on the GeoXH and it appears to be tracking satellites (on COM3).

    COM2 (without GPScorrect) seemed to work in Beta 2, but something seems to have changed in the final version. Any ideas?
    Jason Weis, PE
    GIS Manager
    OMNNI Associates, Inc.
    Appleton, Wisconsin

  2. #2
    Zoltan Kovacs
    Join Date
    Jun 2010
    Posts
    42
    Points
    2
    Answers Provided
    0


    0

    Default Re: ArcPad 10: No GPS on GeoXH

    Hi,

    First thing first, I really recommend a hard reset on your device. As far as I remember, it could restore GPS settings. After, you can try Find GPS tool in ArcPad to find and connect your GPS in ArcPad. I haven't seen AP 10 yet, but in previous version the tool can be found here: in drop-down list below GPS Active icon/ GPS Preferences/ GPS Tab (1st). You should press the black spy-glass icon to automatically find and connect. I hope ESRI left this feature in AP 10...

    If it doesn't work, you can follow the "official" way - what your user guide says:
    - Lanuch GPS Controller on your device and Enable NMEA output in Settings. Set output port to COM2 and baud rate to 4800. (However it is set default on your device, because GeoExplorer 2008 series has 2 ports for outputting data: COM2 for NMEA, COM3 for TSIP.) Than go back to AP 10 and set the same settings for GPS or use Find GPS again.
    Either way should work...

    And don't forget to check Protocol as well! If you set Port and Baud rate settings right, but you leave the protocol on wrong, it won't work! Set it to NMEA. (If you use Find GPS tool, it sets everything for you.)

    Hope this helps.

    Zoltan
    Last edited by opierreo; 07-08-2010 at 08:07 AM.
    Trimble MGIS and
    ESRI Desktop/Mobile GIS Expert

  3. #3
    Jason Weis
    Join Date
    Jan 2010
    Posts
    23
    Points
    1
    Answers Provided
    0


    0

    Default Re: ArcPad 10: No GPS on GeoXH

    I ended up doing an uninstall of ArcPad 10 on the GeoXH, manually removing all folders and files associated with ArcPad and GPScorrect, and reinstalled ArcPad 10. After doing this, ArcPad was able to connect to the GPS on COM2. Hopefully, once the updated version of GPScorrect is released (early Q3 2010 according to my Trimble vendor), I'll have a little more control of the GPS settings again.
    Jason Weis, PE
    GIS Manager
    OMNNI Associates, Inc.
    Appleton, Wisconsin

  4. #4
    Norman Wray
    Join Date
    Aug 2010
    Posts
    4
    Points
    0
    Answers Provided
    0


    0

    Default Re: ArcPad 10: No GPS on GeoXH

    Hi,

    I am still using ArcPad 8 on a trimble Geo XH (2008 series), but I recently ran into the same problem as what you describe (ArcPAD would not connect to the satelite reciever on COM 3). I was eventually able to figure out that the COM port configuration was incorrect in my GPS preferences in ArcPad. According to the user manual for the Geo XH, the settings on COM 3 should be: baud = 38,400, data bits = 8, parity = odd, and stop bits = 1. Somehow my parity had been switched from "odd" to "none." When I changed this setting back, ArcPad connected to the GPS with no problems.

    To check these settings in ArcPad, click on the GPS dropdown and select "GPS Preferences". Under the "GPS" tab (should be the first one) are all of your COM port settings. Just go to COM 3 and make sure that the settings match the manufacturers recommendations.

    Hope that helps.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts