+ Reply to Thread
Results 1 to 2 of 2

Thread: ArcGIS Server 9.3, multi-layer cache for tiling

  1. #1
    Thomas Becker
    Join Date
    Apr 2010
    Posts
    35
    Points
    0
    Answers Provided
    0


    0

    Default ArcGIS Server 9.3, multi-layer cache for tiling

    Dear all,

    I have two grouplayer in an MXD file and after setting up the Map Server Cache as a multi-layer cache type and creating the tiles the behaviour of the sub-layer of the grouplayer is not as expected.

    It doesn't matter if I turn a single sub-layer off or not, it will be shown anyway. Only when I turn the checkbox for the grouplayer off it won't be shown. The layer behave correct concerning the minimum and maximum zoom level to be shown but this other thing bugs me quite a bit.

    I know it sound like guess work but does any of you have an idea? I cheked the settings for the layers and for grouplayer but I can't find e setting to get it right.

    Thanks for your help,

    Thomas

  2. #2
    Andrew Stauffer

    Join Date
    Oct 2009
    Posts
    503
    Points
    146
    Answers Provided
    32


    0

    Default Re: ArcGIS Server 9.3, multi-layer cache for tiling

    Hi Thomas,
    This is expected behavior and the following enhancement request has been logged.

    NIM008501: Enhance the Cache functionality so that when creating a cache from a service with ‘group layers’, currently only the group layer themselves can be selected for multi-layer - enhance to allow the individual layers within the group layer to be selected

    One thing to consider is that there is little to no advantage of using multilayer cache with a Web Application. Multilayer cache is intended to be consumed by desktop products such as ArcMap or a custom Engine application.

    For additional help on designing services for web applications, check out this Blog Post.

    Hope that helps!
    Andrew

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts